Miele XGW 3000 gateway firmware 2.3.1

New firmware the other day. First it was 2.3.0, then quickly after 2.3.1:

Release 2.3.0 – 01.08.2018

  • Improved device sign on
  • Stability improvements and bugfixing

I wonder what’s in 2.3.1, but probably something was broken in 2.3.0, then quickly fixed.

No changes observed so far. Known bugs persist, new ones not discovered yet. That’s not entirely true. I still don’t know if Miele fixed the random change of name of some appliances. In my case it’s always the dishwasher (my only Wi-Fi device), and I have seen it change to “Oven” or “Washing machine”, i.e. names of my other appliances. Update: This bug is still present.

The app

The Miele@mobile app for Android also received an update a few days later (Wednesday, August 8th): version 2.9.4. This app has generally been of great quality, but this time it’s completely broken:

  • Always crashes on first startup. Never happened before.
  • Notifications doesn’t work anymore.
  • The appliance list sorting algorithm is changed from logical to random, e.g. turned off appliances at the top while other appliances are running.
  • Wrong reporting of power consumption. Reports 1.0 kWh when it should be 0.1 kWh (washing machine).
  • Oven program is reported as “APP_MISSING_LOCALIZATIONKEY_-1946157056 (H 5581 BP, XKM 3000 Z). The JSON value for ProgramID is weird (e.g. “2348810240”), don’t know if this bug is in the ZigBee module, the oven or the gateway. However, the app didn’t show this before.
  • When trying to edit product name to default: Object reference not set to an instance of an object.

It seems someone was back from vacation and decided it was time to push out a new release because of the new Miele logo. But forgot that it was still untested. Please fix. Rescue: Version 2.6.0

Leave a Reply